Aquasuite Plugin (BETA)

Questions regarding plugin development and publish plugins

Aquasuite Plugin (BETA)

Postby TheLaGmAn » Wed Aug 27, 2014 10:12 pm

This plugin allows to read Aquasuite sensors and load them into GOverlay.


Download & Install instructions:

Hidden Message: 




Unzip into GOverlay/Plugins/
Close GOverlay.
Start Aquasuite
Enable XML export on aquasuite
Run GOverlay
Enable the Plugin
In the plugin options set the path to the xml file of Aquasuite (if not, it wont work at all)
Look for the sensors in the available elements
Check the logs for any problems


This plugin is more of an alpha than a beta, hasnt been properly tested, only with an example xml file, also keep in mind that the way Aquasuite exports the data into a xml file can use more than normal resources to gather the data.
TheLaGmAn
Site Admin
 
Posts: 611
Joined: Wed Feb 26, 2014 8:32 pm

Re: Aquasuite Plugin (BETA)

Postby PyromaniacB » Thu Aug 28, 2014 1:02 am

Thank you! I will give it a go! I actually had to update to the latest beta to get the plugin to appear in the list, I was still rocking on 1.4.1.
PyromaniacB
 
Posts: 13
Joined: Mon Aug 25, 2014 5:31 am

Re: Aquasuite Plugin (BETA)

Postby PyromaniacB » Thu Aug 28, 2014 1:38 am

Well, I can't get it working in the first place. I installed it according to the instructions and set the log file path C:\Aquasuite.xml.
On startup when reading the sensor, the log gives the following error:
Code: Select all
Error adding plugin sensors: Public member 'DebugLog' on type 'b' not found.

When I go to the sensors, there is a category "Aquasuite" but nothing in it. Upon opening the sensor menu, the log gives the following error:
Code: Select all
Plugin Aquasuite has an error and cant load sensors: Public member 'DebugLog' on type 'b' not found. ::    at Microsoft.VisualBasic.CompilerServices.Symbols.Container.GetMembers(String& MemberName, Boolean ReportErrors)
   at Microsoft.VisualBasic.CompilerServices.NewLateBinding.CallMethod(Container BaseReference, String MethodName, Object[] Arguments, String[] ArgumentNames, Type[] TypeArguments, Boolean[] CopyBack, BindingFlags InvocationFlags, Boolean ReportErrors, ResolutionFailure& Failure)
   at Microsoft.VisualBasic.CompilerServices.NewLateBinding.ObjectLateCall(Object Instance, Type Type, String MemberName, Object[] Arguments, String[] ArgumentNames, Type[] TypeArguments, Boolean[] CopyBack, Boolean IgnoreReturn)
   at Microsoft.VisualBasic.CompilerServices.NewLateBinding.LateCall(Object Instance, Type Type, String MemberName, Object[] Arguments, String[] ArgumentNames, Type[] TypeArguments, Boolean[] CopyBack, Boolean IgnoreReturn)
   at j.a(String A_0)
   at GOverlayPlugin.Aquasuite.Class1.AvailableSensors(Hashtable pluginOptions) in d:\VB\goverlay\GOverlay\GOverlay\bin\Debug\Plugins\Examples\Aquasuite\Class1.vb:line 127
   at f.a(Object A_0, Object A_1, Object A_2, Object A_3)

Did I enter the file path in a wrong format or is there possibly some other issue? I feel bad that I can't do any real troubleshooting myself because I don't understand the programming :(

EDIT: I got it working. I accidentally downloaded beta 13 instead of 14 which threw the error. Let's test it out.

EDIT2: Here are some observations from a bit of testing.

    I tried changing the order of data sources in Aquasuite to be inserted to the xml file and it seems it simply uses the IDs in a left to right fashion from the list starting with AS.1 in GOverlay. So if I add a new data source, it will work fine but supposedly if I'd remove one from the middle it would throw every one after that one off.

    The values seem to slightly "blink" as they update.

    The values do not respect GOverlay's maximum digit or dimension values (e.g. the temperature values have two decimals and I'd like them to have no decimals, or one at most). Having an option for inserting zeros to the beginning would also be nice.

    All sensor data types I currently have access to seem to work fine (Temperature, fan speed, virtual sensor, AIDA64 through Aquasuite). The descriptions in GOverlay are also correct.

    The sensor gathering process and rendering process take about the same time as before. Of course having the Aquasuite running on the background updating the log file uses some extra processing power as expected (around 0.5% in my case).

    The log gives the following message, which I guess is appropriate and it should be there but I thought I'd put it here anyway in case it has some other meaning to it:
    Code: Select all
    AS - Callback Requested: willrequestdisplay
    grabdata: C:\Aquasuite.xml
It's amazing you got a working plugin this fast for me to test and I really appreciate that! Hopefully there can be a way to get the plugin use the shared memory option instead of reading from SSD/HDD. Even though the log file is something like 1-5KB at most, I would prefer Aquasuite not writing to my SSD constantly. With storage HDDs there is of course the problem that it can't ever turn off, wearing it out in the long run.

Thanks again, TheLaGmAn, for your work!
PyromaniacB
 
Posts: 13
Joined: Mon Aug 25, 2014 5:31 am

Re: Aquasuite Plugin (BETA)

Postby kilink » Sat Oct 11, 2014 7:38 pm

thnks
kilink
 
Posts: 6
Joined: Tue Mar 18, 2014 7:23 pm

Re: Aquasuite Plugin (BETA)

Postby PyromaniacB » Tue Dec 16, 2014 3:21 am

Just as a heads up for other people using Aquasuite, the new AIDA64 Extreme Beta versions have Aquasuite support implemented in them, so you can use that to have Aquaero sensor values displayed on the GOverlay LCD as well. This way you won't have to write to a log file from Aquasuite, and you don't need any additional plugins for GOverlay. Works fine for me!
PyromaniacB
 
Posts: 13
Joined: Mon Aug 25, 2014 5:31 am

Re: Aquasuite Plugin (BETA)

Postby Goatee » Fri Mar 13, 2015 11:57 pm

thanks
Goatee
 
Posts: 5
Joined: Tue Mar 10, 2015 8:59 pm

Re: Aquasuite Plugin (BETA)

Postby Vellern » Fri Dec 25, 2015 7:41 am

thx will try
Vellern
 
Posts: 3
Joined: Fri Dec 25, 2015 4:09 am

Re: Aquasuite Plugin (BETA)

Postby ellogo67 » Sat Aug 20, 2016 3:19 pm

Thanks. ;)
ellogo67
 
Posts: 5
Joined: Sat Aug 20, 2016 3:17 pm

Re: Aquasuite Plugin (BETA)

Postby Pupsik » Sat Dec 31, 2016 11:27 pm

thanks
Pupsik
 
Posts: 12
Joined: Thu Jun 25, 2015 3:54 pm

Re: Aquasuite Plugin (BETA)

Postby ciiip » Thu Jan 19, 2017 6:53 am

Thanks
ciiip
 
Posts: 2
Joined: Thu Jan 19, 2017 6:52 am

Next

Return to Plugins Releases and Development



Who is online

Users browsing this forum: No registered users and 2 guests

cron